I suggest you ...

AfterTransfer command - blat not executed

Commands section in my .ini is set in this way:

[Commands]
AfterTransfer=blat "%LOGFILE%" -to destination@xxxx.com -cc destination@xxxx.com -subject "Results - %STATUS%" -server smtp.xxxx.net -f sender@xxxx.com

However, blat command is not executed correctly.
Where do I am wrong?

1 vote
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Mauro shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    under review  ·  AdminCyberKiko FTPSync (Admin, FTPSync) responded  · 

    I’m sorry but I can’t replicate the issue.

    I’ve downloaded latest version of blat, added it to PATH and added this to .ini files:

    [Commands]
    AfterTransfer=blat “LOGFILE” -to support@cyberkiko.com -subject “FTPSync STATUS” -server localhost -f support@cyberkiko.com

    and I’m getting email without a problem (including a production server that generates quite large logs). If PATH wasn’t set, the only change needed was to use full path for blat, e.g.:

    [Commands]
    AfterTransfer=C:\path-to-blat\blat “LOGFILE” -to support@cyberkiko.com -subject “FTPSync STATUS” -server localhost -f support@cyberkiko.com

    What Windows version do you use?

    [Update: it seems percentage sign is lost with UserVoice, but it must be before and after LOGFILE and STATUS words, of course!]

    Best regards
    Kristof Gajsek
    http://cyberkiko.com

    2 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Mauro commented  ·   ·  Flag as inappropriate

        Hi Kristof,
        I have tried your suggestion with no success.
        I have also tried to replace "%LOGFILE%" with a simple "test.txt" but it also did not work.
        The same command executed from command line works fine.
        The same batch file, executed in ftpsync folder with command line works, if added as AfterTransfer parameter it did not work
        It seems like ftpsync in some way close down the process before blat is able to execute

      • Mauro commented  ·   ·  Flag as inappropriate

        Thank you for your reply Kristof.

        Yes, blat has been of course downloaded and path has been set properly.
        I have also copied blat in FTPSync directory just to be double sure.

        I have run blat from command line and it works correctly, which is really weird.

        Looking at the log, I cannot see any error. Here is an example:

        End: 23-mar-2017 09:37:46
        Executing after transfer command...
        CleanUp started...
        Saving MTB file: C:\xxxx.mtb
        Exit code: 0

        This problem is getting me mad... any other idea?

      Feedback and Knowledge Base